排查 reCAPTCHA 网站密钥的域名无效问题 列印

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症状

所有受 reCAPTCHA 保护的区域(如客户区登录、管理区登录、结账页面等)都会显示以下错误,导致表单无法提交:

 

recaptcha_invalid_domain_for_site_key.png

原因

只有当 WHMCS 管理区中配置的 reCAPTCHA 网站密钥未授权当前域名时,才会显示此错误。最常见的情况是 WHMCS 迁移到了不同的域名或子域名。

解决方法

方法一:添加正确的域名

解决此问题最有效的方法是将正确的域名添加到网站密钥中:

 

  1. 访问 https://www.google.com/recaptcha/admin 并登录您的 Google 账户。
  2. 从下拉列表中选择正确的网站密钥。
    reCAPTCHA
  3. 点击 “设置”。
    reCAPTCHA
  4. 在 “域名” 部分,添加正确的域名。
     
    reCAPTCHA
  5. (可选)此时您可以删除不正确的域名。

方法二:禁用验证码

另一种解决此问题的方法是禁用验证码。此方法仅建议在您无法访问 Google reCAPTCHA 账户时使用。

 

此方法需要对数据库执行查询。请确保在执行查询前对数据库进行完整备份。

 

要从数据库中禁用验证码,请打开您常用的数据库管理工具(可以是命令行或 phpMyAdmin 等工具)。本示例将使用 phpMyAdmin。

 

  1. 在左侧导航面板中点击数据库名称,选择您的 WHMCS 数据库。

     

    v79.test.whmcs.rocks / localhost / v79whmcssupport_whmcs | phpMyAdmin 4.9.0.1
  2. 接下来,点击 “SQL” 标签。
     
    v79.test.whmcs.rocks / localhost / v79whmcssupport_whmcs | phpMyAdmin 4.9.0.1
  3. 将以下查询粘贴到 “运行 SQL 查询” 框中:
    UPDATE tblconfiguration SET value = '' WHERE setting = 'CaptchaSetting';
  4. 点击 “执行”。

     

    Banners and Alerts
  5. 会显示成功消息。此时验证码已禁用,您可以重新登录 WHMCS 管理区设置新的 reCAPTCHA 密钥。

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