症状
管理员可能会收到一封POP3连接错误报告邮件,提示一个或多个POP3连接失败:
错误:无法连接到主机;错误 = stream_socket_client():无法连接到 (php_network_getaddresses: getaddrinfo失败:名称或服务未知)(errno = 0)
当在“邮件导入设置”中测试连接时,测试会失败。
若连接测试成功,请参阅排查“无法连接到主机(php_network_getaddresses: getaddrinfo失败:名称或服务未知)”错误。
原因
系统无法解析支持部门邮件导入配置中无效或不可达的主机名。
解决方法
按以下步骤解决问题:
-
进入 设定 > 系统设定 > 支持部门。
-
编辑相关支持部门。
-
确保“主机名”字段中输入了正确的邮件服务器主机名(检查是否有空格或拼写错误)。
-
确认输入了正确的IMAP或POP端口号。
-
点击 保存更改。
-
通过服务器命令行确认可连接到邮件服务器(例如使用
telnet
命令):成功连接可能返回以下结果:
若返回以下响应,可能表示服务器无法解析主机名:
这可能表明服务器存在DNS配置错误。
若返回以下响应,可能表示服务器无法连接到主机名:
这可能表明邮件服务器当前不可用,或防火墙配置阻止了连接。
请将测试结果联系系统管理员或网络提供商,进一步排查并解决连接问题。